MiCC SMS provider

Home Forums Contact Center MiContact Center Business MiCC SMS provider

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  Eric Laracuente 3 weeks, 3 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5513

    Kurt Bobinger
    Participant

    I am in the process of creating a MM queue. I see when creating a Media server, the only provider I see is Twilio. Can we use an alternate SMS provider? We have an account with Bandwidth.com and are wanting to use an SMS account with them. TIA!

    #5521

    Eric Laracuente
    Participant

    Hi Kurt,

    As far as I know (current to MiCC ver 9.1), Twillio is the partner of choice, but there are plans to open it up in further versions. Now if you work with your partner, they can work with Mitel on ways to do so custom.

    Now in terms of specifics on your SMS gateway provider being fully supported once opened up, that’s an unknown to me. I hope this helps!

    Thanks!

    #5545

    Kurt Bobinger
    Participant

    Ok, we got our Twilio account and I have configured the MiCC per documentation instructions, which is very straight forward. When a text is sent to the Twilio number. I see no record of the SMS message hitting the MiCC server. Any suggestions where I can verify? I do see the the Twilio Account connected when I view using baretail. Thanks!

    #5546

    Eric Laracuente
    Participant

    I would recommend checking the following:

    1) From the Twillio account, can you see records of that text message?
    2) Restart the inbound MiContact Center Inbound Router service on your MiCC Server (would recommend after hours, you will get an alarm for this one)
    3) Check the RoutingInboundService.log under the [MiCC]\Logs folder to see if there is any indication of that communication being received.
    4) Check your Inbound Workflow for the queue in question.

    If you’ve set up other Multimedia queues in the past, this one should follow the same behavior regarding scheduling, inbound routing, queue, and agent group assignment; make sure you have all these configured.

    I hope this can help. I’ll keep on digging for you and report back.

    Thanks!

    #5547

    Kurt Bobinger
    Participant

    I would recommend checking the following:

    1) From the Twillio account, can you see records of that text message? Yes, they are there
    2) Restart the inbound MiContact Center Inbound Router service on your MiCC Server (would recommend after hours, you will get an alarm for this one) Restarted this service, no change
    3) Check the RoutingInboundService.log under the [MiCC]\Logs folder to see if there is any indication of that communication being received. No record of ANY SMS communication
    4) Check your Inbound Workflow for the queue in question. inbound workflow is configured properly, we already have email and web chat working properly.

    #5548

    Eric Laracuente
    Participant

    Thanks for the reply!

    Any network requirements from Twillio? Any firewall ports required to be open for the communication as well as certificates? If there are no records at all on the server, it can be network related (possible).

    #5564

    Kurt Bobinger
    Participant

    I have good news to report. After upgrading to release 8.1.4.1 and applying hotfix KB466672, we are now able to receive SMS conversations via Ignite.

    However, I have one other question/opportunity. We want to be able to send an auto reply stating that the business is closed after hours and during holidays. I am able to accomplish this by using the business schedule, however we would like for this “auto-reply be sent if no agents are logged into Ignite. I was able to accomplish this with the email queue, by adding an interflow to the over-flow action then setting the queue to allow overflow and overflow when no agents are logged in. when I do this in the SMS inqueue workflow, I get a validation warning. I feel like I’m missing a very small piece to accomplish this. Any an all comments are welcome!

    #5565

    Eric Laracuente
    Participant

    Excellent news about the update fixing your issues. Impressive what led to that conclusion, so if you can drop us some details much appreciated.

    Regarding the workflow validation issue, maybe try clicking on an empty space of your workflow/subroutine and select properties. There should be a “Validate workflow” checkbox there, check it and save the workflow.

    See if this helps.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.